Secure FTP Applet

For the latest version of Secure FTP Applet go to JSCAPE at www.jscape.com

Note: This FTP Connection requires that you accept the security dialog displayed and have Java-Plugin version 1.4.2 installed. If the applet below does not appear or appears as a grey screen then your current Java virtual machine may not be compatible with Secure FTP Applet. To run Secure FTP Applet please download Java-Plugin version 1.4.2.

Remember This is for Pictures only JPG files will only upload to here

Close This window when you are done your uploads Close Window